Error Starting with DotSpatial (Project DemoMap)

Jun 7, 2013 at 3:55 PM
Hi! I have a little problem with the project DemoMAP.

I downloaded the source code of section downloads for this page. Then i followed the next instructions of how compilate the solution:

http://www.youtube.com/watch?v=hnj2gMCBAnE

Finally, i put the DemoMap as Startup project and when the applicaction is initializing jump the next mistake:

No se puede cargar el tipo 'System.Runtime.CompilerServices.ExtensionAttribute' del ensamblado'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

In the next cs: DotSpatial.Controls.AppManager:

private static void TryLoadingCatalog(AggregateCatalog catalog, ComposablePartCatalog cat)
    {
        try
        {
            // We call Parts.Count simply to load the dlls in this directory, so that we can          determine whether they will load properly.
            if (cat.Parts.Count() > 0)             //// Here is the mistake!
                catalog.Catalogs.Add(cat);
        }


Somebody can help me for run the DemoMap project???

Thanks!
Jun 12, 2013 at 6:30 PM
Hi Alberto
Have you see if yor version .net framework is 4 on demomap project? Are you in win xp?
Jun 12, 2013 at 6:45 PM
Edited Jun 13, 2013 at 10:04 AM
Ei Sannavtar, thanks for your answer but i solved this mistake with following steps in Windows 7, 64 bits:
  1. Install Visual Studio 2012
  2. In solution explorer, delete Test project
  3. Install the diferents packages of NuGets at Tools/Library Package Manage/Manage NuGet Packages
  4. Compile solution.
  5. Set DemoMap project as Main project
Regards.
Sep 14, 2013 at 6:23 PM
Edited Oct 2, 2013 at 4:10 PM
Hello,

sorry to renew an old thread, but I have the exact same problem as Alberto_GIS had. I am running VS2010 on Windows XP Sp3. As it is XP no .NET Framework 4.5 was ever installed. Tried to change the project DemoMap target framework from .NET 4 Client profile to .NET 4, but that didn't hel as well. Any hints or ides would be greatly appreciated.

Cheers

Edit: For those who might have the same problem. The solution for me was to change the Platform in Configuration Manager to "x86" for all projects.

Edit2: Sorry, but my solution posted higher didn't really work. After some research I found out the the compiled dlls from the Project "DotSpatial.Plugins.WebMap" where causing this problem. After Downloading the new sources today I found out that the problem is no more. Wrote this just to clarify things.

Thank You DotSpatial Team for solving this.