This project is read-only.

Could not detect Virtual GPS using DotSpatial.Postition's DemoGPS

Oct 20, 2012 at 9:16 AM

Hi all,


Recently, I have downloaded dotspatial source code and also downloaded an application Virtual GPS ( to simulate GPS receiver.


When I run DemoGPS project which is available in dotSpatial source code, it is unable to detect Virtual GPS and its data on COM1 port. Sometimes DemoGPS says "Access to the port 'COM1' is denied." and sometimes it says "A security PIN entered for COM1 was incorrect. The device should be re-paired in the bluetooth Manager." 


I have configured COM1 port from Device manager with the option given in the Virtual GPS's setting. (Serial Port= COM1, Baud Rate= 4800 ) and I ran out of idea to address the issue.


Basically, Im trying to write an exe to detect GPS device (which can emit NMEA or Garmin or Magellan data). Also, I need to simulate GPS device.


Can someone help me in resolving the issue or suggest other ways to achieve simulating GPS device to develop an application.


Please let me know if further information is needed.