Where to find 3.5 Binaries

Jan 5, 2012 at 3:49 AM

I found an earlier thread (http://dotspatial.codeplex.com/discussions/257319) that made reference to 3.5 binaries being made available. Were these ever published? If not, does the latest changeset still build, if retargeted for 3.5

Unfortunately upgrading to 4.0 is not an option in this case, as I'm making a plugin for a 3rd party codebase that targets 3.5

Thanks for any help

Developer
Jan 6, 2012 at 7:38 PM

I've made the DotSpatial 1.0.2011.4 Beta Release (4th April 2011) available. This release to too buggy for us to recommend it, but it seems that it can be compiled against .NET 3.5

Jan 9, 2012 at 3:52 PM

I see it: http://dotspatial.codeplex.com/releases/view/64984

Thanks for the quick response. I will give it a shot and see how well it works.

Jan 14, 2012 at 12:13 AM

Sorry to be a pain. The binaries worked like a charm in dev; but when i went to deploy to a x64 platform they bombed out...

It looks like these aren't built with the anycpu option and instead targets x86. I tried using corflags to fix, however the assemblies are signed so my efforts were futile.

Can you post a fixed build or should i just try and build from source?

 

Thanks again for your help

Developer
Jan 14, 2012 at 3:56 PM

You may be able to get the x86 dlls to load on the 64 bit platform if it supports WOW. I was able to load DemoMap from this release on a 64 bit machine.

This release is really old and not supported, but you can also find the source at http://dotspatial.codeplex.com/SourceControl/changeset/view/f9b594cae9af and try compiling it. (Hit the Download button on the right of the source tree).

Feb 9, 2012 at 4:41 AM

Just a quick update for anyone interested in compiling for 3.5. I was able to make this work, however I did have have to update several of the class files nothing major at this point just removing some of the 4.0 specific code.

Developer
Feb 9, 2012 at 2:35 PM

If it is removing code, can you use ifdef, and submit a patch?

http://stackoverflow.com/questions/1205908/what-net-framework-and-c-sharp-version-should-i-target-with-my-class-library

TeamCity (automated build system) can setup a compile flag to do a 3.5 build