Toolmanager question

Nov 20, 2011 at 6:30 PM

On the latest dotspatial release (RC2), I can't find the option Tool directories in the toolmanager, as shown on the screen cast. How do I set it properly, so I can use tools that are provided?

Developer
Nov 21, 2011 at 6:29 PM
Edited Nov 21, 2011 at 6:41 PM

You don't need to set Tools directories any longer. I'll look at creating new documentation in this regard. Just include a Tools.dll in the Plugins or Tools folder.

Nov 21, 2011 at 11:27 PM

Looking forward for documentation as I am confused. I added existing item (tools folder) in my solution but nothing happened... Thank you

Developer
Nov 23, 2011 at 1:20 AM

I've posted an article to http://wp.me/pvy5A-1X

Does this help?

Nov 23, 2011 at 10:22 AM

Yes it does :-) According to your post I managed to solve issues I had with earlier versions and gdal.  In combination with http://dotspatial.codeplex.com/discussions/276309 finally got the tools loaded.

I did not use

using System.ComponentModel.Composition;


appManager.CompositionContainer.ComposeParts(toolManager1);

May 5, 2013 at 5:51 PM
Hi.

Mudung I did as you said and I don't have the toolbox loaded in my form . I don't know what's wrong .

Please can you help me ?
May 5, 2013 at 6:09 PM
Can some one help me please, it's very urgent : (
May 5, 2013 at 7:54 PM
It's fixed now , I just added these code lines :

appManager1.LoadExtensions();
appManager1.CompositionContainer.ComposeParts(toolManager1);

and added the tool folder to my project and it worked.
Jun 28, 2013 at 8:09 PM
Luffy16

Can you elaborate your fix.
I'm lost
"added the tool folder to my project",


where is the tool folder and what files are needed

thank
Oct 26, 2014 at 7:01 AM
ytlee - just go into the dotspatial folder and copy the tools folder into your project's plugins folder.