GDAL with DotSpatial version 0.11.9.6

Oct 6, 2011 at 11:51 PM

Hi all,

I have updated my DotSpatial libraries to version 0.11.9.6 (2011/07/27 - DotSpatial_x86_DotNET4.0_Release.0.11.9.6.zip) and I'm facing some problems with Images.

Before that, I could successfully open tif images (with those size limitations). With this new version, I can't.

Here goes some questions / commentaries:

1. Inside the DotSpatial_x86_DotNET4.0_Release.0.11.9.6.zip has some gdal dlls at the root folder (DotSpatial_x86_DotNET4.0_Release.0.11.9.6) and also inside the folder DotSpatial_x86_DotNET4.0_Release.0.11.9.6\Data Extensions\GDAL

2. When I try to load some image (tif 80 MB wich loads perfect in past version 1.0.2011.5), I got de error message:

{"Could not load file or assembly 'gdal_csharp, Version=1.0.4040.43045, Culture=neutral, PublicKeyToken=db5a52b08dc5b321' or one of its dependencies. The system cannot find the file specified.":"gdal_csharp, Version=1.0.4040.43045, Culture=neutral, PublicKeyToken=db5a52b08dc5b321"} 

 I have tried a 2 MB jpg image and got the same error.

3. I've noticed that now exists a new dll called: DotSpatial.Data.Rasters.GdalExtension.dll so I decide to add its reference. Got the same error in both images.

4. I tried to delete the GDAL folder and put the GDAL folder/ddls that I used before (with DotSpatial 1.0.2011.5) inside the Data Extensions folder. In this test, the GDAL file types option doesn't appeared in the open dialog.

Could someone help me?

What is the correct way to use the GDAL libraries?

Thanks,

Evemar

Developer
Oct 7, 2011 at 6:31 PM

I've posted a new release that should fix your issue: http://dotspatial.codeplex.com/releases/view/73065

Oct 7, 2011 at 6:53 PM

Thank you!

I am downloading right now!