This project is read-only.

lots of errors after upgrading to DotSpatial 10-27-2010

Oct 28, 2010 at 3:14 AM

Almost every line related to DotSpatial causes an error after upgrading to latest release, DotSpatial 10-27-2010. That 25.10 release did the same thing. Code is still the same, didn't change that in any way.

E.g. "Imports DotSpatial.Controls" -> "Namespace of type specified in the Import 'DotSpatial.Controls' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases"

And "Me.SpatialToolStrip1 = New DotSpatial.Controls.SpatialToolStrip()" -> "Type 'DotSpatial.Controls.SpatialToolStrip' is not defined"

I did the upgrade as earlier, copy the new DLL files over the old ones, checked from the project references that the new DLLs were there.

Did I do something wrong, or should I do something differently or is there something I should know regarding this latest upgrade? I tried to check all the last/latest upgrade notes, but didn't find anything which gives a hint.

I used x86 package, as I'm using 32 bit WinXPPro SP3.

Oct 28, 2010 at 4:05 PM

No, everything is fine.  We are just using a new, auto-incrementing version number for the library release.  In the solution explorer, you will need to go to the references, right click and choose properties, and then in the property window, set "Specific Version" to false.  This is something that we should have done a long time ago, but we never did.  Every release was say 1.0.0.0 or whatever.  Now it will be 1.0.0.123456 or something useful like that.  Once you toggle that setting it should stop complaining.

Ted

 

Oct 28, 2010 at 7:41 PM

And so it did, thank you.