Slow loading of raster files in DotSpatial 1.7

Jul 28, 2014 at 10:50 AM
Hello

I have started upgrading my application from DotSpatial 1.4 to DotSpatial 1.7. I have noticed that rasters are now loading quite a bit slower in 1.7 compared to 1.4.
I built the same simple test application using both 1.7 and 1.4. I am using map.AddRasterLayer(). The test raster file I used was a 49 mb geotiff. The following are the results of my tests.
Version Time to Load Raster
1.4 ~11 seconds
1.7 ~22 seconds.

Has anybody else experience this? Is there any known reason for this change in performance, and is there any way I can improve the performance of 1.7.

Cheers

Hamish
Developer
Jul 28, 2014 at 10:57 AM
Hello,

it's strange. did you tried several times to calculate the time? it should be the same for 1.4 and 1.7.

Maxim.
Jul 28, 2014 at 8:11 PM
Hi Maxim

I have repeated the test several times on the same computer. I am happy to share the geotiff that I am using.

I was wondering if it has something to do with changes in the way GDAL was implemented between 1.4 and 1.7.

Cheers

Hamish
Developer
Jul 28, 2014 at 8:18 PM
Yes, please share the file. I'll compare loading at my pc.
Jul 28, 2014 at 9:26 PM
Thank you for looking at this.

http://1drv.ms/WKnJHp

Cheers

Hamish
Developer
Jul 29, 2014 at 11:54 AM
Hamish, i've tried both 1.4 and 1.7 and there is no big difference at all in time loading. In both cases it loads about 5-6 secs.
In both cases I've tried demomap applicaton. Maybe you are comparing Debug and Release configurations? in this case the difference may be x2 times.
Jul 31, 2014 at 1:15 AM
Hello Maxim

Thank you for all your help. I worked out what my problem was. I was building the application in Visual Studio 2013 using the "Any CPU" setting and was getting the times I quoted above using either Debug or Release. However when I changed it to either "x86" or "x64" mode the raster, loaded in times close to what you quoted i.e. 5-6 secs.

Cheers

Hamish
Marked as answer by jany_ on 9/9/2014 at 1:29 AM