This project is read-only.

Differences between FeatureSet and Shapefile objects...

Jul 13, 2012 at 1:38 AM


I'm working on resolving an issue (ID:23004).

And have found some interesting misunderstandings or complications?

First to partially solve the issue I had to remove references to FeatureSets in the project I was saving and make these references to Shapefile objects. This broke other things as you can imagine.

So I tried to create Shapefile objects first off and add them to the map, however when I tried to edit (add features) to these the map UI would not update. However when I used FeatureSet all worked fine.

What is the difference between these objects (or meant to be?). It is slightly confusing that FeatureSet has SaveAs shapefile and works fine upto the point of saving a project (.dspx file). And if you use Shapefile objects the map control won’t update as with the use of FeatureSet. I have to admit the I achieved this by using something that I didn’t like Featuresetobj.Symbology.CopyProperties(Featuresetobj.Symbology); at the end of adding new features.

I’m starting to think I have something conceptually wrong with the use of the library cause what I would have thought as basic concepts of a GIS control seem to be getting quite complex (or hit or miss)

Welcome Ideas, links. Thanks

Jul 19, 2012 at 4:52 AM

Still having problem with Shapefiles and FeatureSets.

Especially when saving a project file, can get the map to save. However when I add a feature, get error.

Details are in

Sep 18, 2012 at 11:30 PM

we could sure use more examples, code snippets and such to get a better feeling about whats possible....