This project is read-only.

Error in build 'DotSpatial.Positioning'

Mar 7, 2012 at 7:33 AM
Edited Mar 7, 2012 at 7:36 AM

Hello Folks!

I can not build 'DotSpatial.Positioning' successfully due to some bad characters in the source file. Just like the following: 

newValue.Replace("?, " ").Replace("'", " ").Replace("\"", " ").Replace("  ", " ");

By the way, I'm trying to build it with Microsoft visual studio 2010 prepositional (Chinese) on Windows 7.

Please help, thank you! 



Mar 7, 2012 at 4:54 PM

I've heard of someone else that had that problem, too. You want to use this line

newValue.Replace("°"" ").Replace("'"" ").Replace("\""" ").Replace("  "" ");

You can also browse the source online.

Mar 8, 2012 at 6:17 AM

Hi again!

The source on line also have the same problem, just like <format = "HH�MM'SS.SSSS\"i";>.

May be it caused by my OS(Win7 Chinese). Is the sources saved as ASCII or UNICODE?




Mar 8, 2012 at 9:04 PM

$/dotSpatial/DotSpatial.Positioning/DotSpatial.Positioning/Angle.cs etc were in Windows-1252 Encoding.

I've modified these in the latest checkin. Does this help?

Mar 9, 2012 at 12:02 PM

Hello mudnug!

Thanks for attempting to help! But it still doesn't work. I believe save all the sources as UTF-8 encoding will be OK!



Mar 9, 2012 at 9:23 PM

Which one is causing the problem, now?

Mar 10, 2012 at 7:05 AM
Edited Mar 10, 2012 at 7:07 AM

It's still the old problem, just like <format = "HH�MM'SS.SSSS\"i";>!

UTF-8 is the right encoding format for the non-anscii characters, and it supported by almost every computer in the world.

Mar 12, 2012 at 8:32 PM

The encoding on $/dotSpatial/DotSpatial.Positioning/DotSpatial.Positioning/Latitude.cs and $/dotSpatial/DotSpatial.Positioning/DotSpatial.Positioning/Longitude.cs is already utf-8.

Sorry that didn't help you.

Mar 12, 2012 at 8:32 PM

The string should look like 

format = "HH°MM'SS.SSSS\"i";
Mar 13, 2012 at 9:38 AM

Hello mudnug!

Maybe we are struggling on a simple problem.

I open the 'Longitude.cs ' with programmer's notepad, and it show that the source is encoded with ANSI but not UTF-8, are you sure you have re-encoded the source file?

Could you send the 'Longitude.cs' file directly to my mail box( as a attachment. Two copy of the 'Longitude.cs' can easy us to locate the problem: one copy encoded in ANSI and another encoded in UTF-8. Thanks.

By the way, Windows-1252 is the default encoding style for Western Europe, but it's not the case for other parts of the world.

Please encode the  source file 'Longitude.cs'  with UTF-8 and send it to '', then we can locate the problem.

Thanks for help.

Mar 13, 2012 at 5:45 PM

Here is the file:

I've re-encoded the files as UTF-8 with signature.

It seems the encoding to UTF-8 didn't really do much.

See the latest changeset for the rest of the files.

Mar 14, 2012 at 6:20 AM
Edited Mar 14, 2012 at 6:26 AM

Hello again!

It worked! The file ''  re-encoded with UTF-8 can display correctly on my system.

So please re-encode all sources include '°' with UTF-8,It will help a lot for the developers and users  from non-English speaking countries.

Thanks a lot for help.



Mar 14, 2012 at 7:33 PM
Edited Mar 14, 2012 at 7:33 PM

Glad to hear of your success. Good news, as re-encoding was already done.

See the latest changeset for the rest of the files.

Mar 22, 2012 at 3:11 PM

Hello mudung!

Would you please save the 'Area.cs' to UTF-8,  there are many characters can not display correctly on my system. Just like the following:

format = format.Replace("U", "cm?);


Thank you in advance.

Mar 22, 2012 at 4:36 PM

OK. See changeset Fix: encode Area.cs as UTF-8

Mar 22, 2012 at 6:25 PM

The “Compass.cs” file in the solution ' DotSpatial.Positioning.Forms' has to be converted to UTF-8 due to some un-ansi characters. 

Thank you.

Mar 22, 2012 at 8:44 PM