This project is read-only.

Renamed MapFunctions. Proposed simliar rename of ModelElements and Params.

Nov 14, 2010 at 8:37 PM

Formerly, the MapFunction that handled selection, for instance, was SelectFunction.  While this makes perfect sense, it meant that the functions were scattered all over the Controls library.  I have subsequently named them after the fashion: MapFunctionSelect, so that all the classes that inherit from MapFunction are grouped together.  This should be useful both in the solution explorer and in intellisense when looking for what existing MapFunctions we have are.

It might be useful to rename the ModelElements and Params the same way.  Formerly it didn't matter because everything was in subfolders anyway.  But if we are going with a flat architecture, it might be good to use sortable nomenclature.

Any objections to the ModelElement and Parameter renaming should happen before next weekend or else I will consider a done deal.