This project is read-only.

Failed to download the repository

Nov 2, 2010 at 6:44 PM
Edited Nov 3, 2010 at 2:34 PM

Hello. I do not know if this is the place to discuss it (if not the correct forum, please move it).

When you try to download the whole repository from TortoiseHg (WinXP...), the program throws me this error:


real URL is
destination directory: DotSpatial
requesting all changes
adding changesets
adding manifests
adding file changes
transaction abort!
rollback completed
abort: premature EOF reading chunk (got 1381321 bytes, expected 1852602)

[command interrupted]

I searched the internet, and forums say that the server can be without resources ... Can you check if it only happens to me?. A greeting.


Nov 2, 2010 at 7:25 PM
Suspect that codeplex is having issues during the Microsoft PDC.
I got bounced while trying to downloading a zip file
Nov 2, 2010 at 8:48 PM

I've had this problem from day 1 and I've tried every avenue at my disposal... DotSpatial, Codeplex, Mercurial, etc.  Problem is a timeout on the Codeplex server.  Your and my connections may be slower than some others.  If you look here at the previous thread, you can learn more and see a workaround.



Nov 3, 2010 at 12:10 PM

Thank you Kellison, i used the solution proposed in the post and works!...

I think the repository needs to "lighten up" to avoid these problems in the future.

Nov 12, 2010 at 1:06 AM

I had the same problem when trying to get DotSpatial source code to my laptop. The following steps worked for me:

  1. Use TortoiseHg Clone and check the "Clone to revision" box.  Enter the hex id for the very first revision (b912aaca7751).
  2. Right-click on the folder and use TortoiseHg Synchronize. Enter c57e74dc86d9 in the 'Target revision:' text box. This will pull files until the Aug 29 revision.
  3. Repeat the Synchronize step with 3385cab7f19 (Sep 27) target revision
  4. Repeat the step with 24ac57b4af4b
  5. Repeat the step with blank target revision (this will pull the remaining changesets)
  6. Run TortoiseHg Update.

Remark: More intermediate steps may be required if the connection is very slow.

Mar 1, 2011 at 4:28 PM

Tried the steps described above with no success.  I am having problems now even downloading changesets.  Connection on my end is not slow.  Fails with the following error:

comparing with
abort: premature EOF reading chunk (got 1239347 bytes, expected 13817164)

Mar 1, 2011 at 8:29 PM
Edited Mar 1, 2011 at 8:40 PM

I recently took jirikadlec2's approach. You don't need to specify cryptic numbers, it is sufficient to supply changeset numbers in the sequence 1 to last revision.

I started of with Clone to revision 100. After that I used the Synchronize tool and added 100 for each step. If a step failed, I got a similar message than you did. I retried with an additional 50.

I set Synchronize to update after each pull (combobox in the top left corner).

Hth FObermaier

P.S. I have a strong suspicion that this has to do with the binaries (gdal, et. al) stored in the repository, maybe we are better of using some tool like unix' wget to load them on demand from someplace else.

Mar 1, 2011 at 10:23 PM

Hey folks. Jiri has written a batch file that should automate the setting up of the repository for the first time. I'm trying now and will report. 

Mar 2, 2011 at 1:04 AM


I have created a .bat file to automate setting up of the repository for the first time. Steps to use:

  1. Go to Getting Source Code page
  2. Download the attached file clone.bat, copy it to the Program Files\TortoiseHG folder and run it

This will download the DotSpatial code and should work better than the previously described approach. Could you please test cloning DotSpatial code using clone.bat and report any issues.



Mar 2, 2011 at 4:03 PM

Bat file worked.