This project is read-only.

failed to add DotSpatial.Desktop.dll

Sep 27, 2010 at 1:34 AM
Edited Sep 27, 2010 at 1:35 AM

When trying to add DotSpatial.Desktop.dll to visual studio Toolbox(following developer's corner's instructions), I received error message: "(path)\DotSpatial.Desktop.dll is not a Microsoft .NET module". Any idea what might be the problem? I can add the old MapWindow.dll without any problem. I downloaded the package a few times just in case, but the result was always the same.

Sep 27, 2010 at 4:34 AM

Are you using VS2010?  I haven't gotten around to creating a 3.5 zip of the DotSpatial library, and the newest refactoring effort even changes this to DotSpatial.Controls instead, but either way, we would have to specifically target .Net 3.5 in order to allow you to build to VS2008.  Other than that, nothing comes to mind as to what would cause that kind of message.



Sep 27, 2010 at 5:49 AM

I'm using VS2008 and .NET 3.5. So do I need to reverse back to earlier version of .NET Framework, and if so, which one?

Sep 27, 2010 at 10:53 AM

I'm receiving the same message with VS2005 with .NET 2.0 and VS2008 with .NET 3.5. I'm trying to load the DotSpatial.Desktop.dll that comes with the 12-Sep-2010 release.

Sep 27, 2010 at 12:01 PM
Edited Sep 27, 2010 at 12:14 PM

I tried with .NET 4.0, didn't work and if it doesn't work with earlier version, then not sure what to do, maybe upgrading to VS2010? MS provides a trial version for VS2010, I'll give it a go and see if that works out.

Sep 27, 2010 at 9:12 PM

Can you see if the artifact from here works?

log in as guest


Sep 27, 2010 at 9:58 PM

I got the same error message after trying with "DotSpatial targeted at 4.0"(from the website indicated in the post above), since I upgraded .NET to 4.0. Didn't try to reverse back and try with the other package, somehow got a feeling that it might not work either.

That trial version of VS2010 from MS managed to read DotSpatial.Desktop.dll into my project without any problems though. Looks like it might be the earlier versions of VS which cause the problem?

Sep 27, 2010 at 10:04 PM

It is my understanding that VS2008 and earlier cannot use .Net 4.0 at all.  If you created a project in VS2008 and attempted to target 4.0, I don't think you would find that option available.  You need to use a VS2010 variant or something like CodeDevelop, which have had the IDE re-configured to work with 4.0.



Sep 28, 2010 at 3:38 AM

Yes, I noticed, but I thought it's OS problem and I can install it into my PC. Well, anyway, now I know how to overcome that problem.

Sep 28, 2010 at 5:16 PM

I tried to follow the link above so that I could post a shortcut to the 3.5 auto-build binaries on our download page, but I just got a connection failure.  Are you sure we can connect directly to that from outside?

I just get "Firefox can't establish a connection to the server at" and some advice about trying again later.  Or was the server down?



Oct 2, 2010 at 1:43 AM

Could be a firewall issue, since it is on port 88 (no urgent need to address that issue).

You might need to go to:

and click log in as guest first. But I get taken to a login link